A while back I upgraded npm to version 5 using

npm install -g npm@latest

or

npm install -g npm@5

not really realising that SPFx doesn’t support version 5 of npm (yet). I had to downgrade npm.

running npm install -g npm@3 seemed to be to obvious but that didn’t work:

I tried uninstalling node.js and I tried removing the npm.cmd command mentioned, but all didn’t work.

then I came across the folder C:\Users\myusername\AppData\Roaming with a folder npm and npm-cache

I removed these two folders and then reinstalled node.js. and now npm -v returns the correct version:

Advertisements